New Badlander Issue

The Boogie Board

Help Support The Boogie Board:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Joined
Jan 23, 2024
Messages
31
Reaction score
11
Location
Trinidad

Need some help, having a strange issue. As u can hear in the vids the amp when not playing sound like it’s getting interference then pops. When playing this results in a louder volume when the interference is happening and when the boop happens the volume drops. Any ideas. It’s a Badlander 100 with MR scary mod.
 
+1 on remove the mod and repeat. It could be a bad tube in the Scary mod. Does it have the toggle switch on it? could be a defect in some wiring. Send Legendary Tones an email and copy the video (s) see what they say about it. Did the amp make this noise before the mod? When trouble shooting issues, look back before you made any mods or changes, was it present before or only after the change?
 
+1 on remove the mod and repeat. It could be a bad tube in the Scary mod. Does it have the toggle switch on it? could be a defect in some wiring. Send Legendary Tones an email and copy the video (s) see what they say about it. Did the amp make this noise before the mod? When trouble shooting issues, look back before you made any mods or changes, was it present before or only after the change?
Ok will try that. The mod has been in there a month or so with no issues thow.
 
amps, cars, guitars, hardware controllers.... good rule of thumb on anything is if something breaks, it's probably your mod. no offense meant to legendary tones, I'm speaking more from experience in aftermarket motorsports stuff, but smaller shops are often limited to testing things to see if they work, and not necessarily how they hold up. Just how it works, all engineering is compromises.

User pools for aftermerket engineering products are often dramatically smaller than you think, particularly because people often buy them on spec and don't install them immediately (or ever). For example (I have no idea if this is actually the case) you may well be the first person to put 50+ on/off cycles on a Badlander with the mr. scary...
 
So I grabbed a new ecc83 and took out the mod and swapped it in and it didn’t fix the issue. So I then did the remaining 4 slots one by one and it didn’t fix the issue. So I decided to swap out the JJ EL 34IIs for the stock Mesa EL34 tubes that came with the amp and it has seemed to have solved the issue. This is really odd as the JJs are just under 2 months old and from eurotubes which I have never had an issue. It is what it is, I am really praying this is fixed now. I attached vids so u can hear the oscillation from the JJ’s vs the Mesa.

 
So this issue is not as Scary as it seemed to be. Pun intended.

Ah, JJ EL34 power tubes, Sort of reminds me when I tried a quad of their 6CA7 tubes. I had one tube that kept cutting in and out. It was in a Mark V90. The tubes sounded great but that only lasted 2 weeks. Had a different sound, more like the amp was red plating.

If the tube is cutting out, you can see that if you can view the cathode, there should be a blue corona around the cathode if the tube is operating, if it cuts out that blue corona goes away. I found that most EL34 tubes do not have that blue glow on the glass like most 6L6 tubes, but if there are holes in the plates, you can see the cathode. Along its edge will be the blue color, if you look directly at it, it will appear orange.
 
I really hope its not at "Scary" as it seems lol. Will update later. Actually didnt notice anything out of the ordinary with the JJs but I didnt really pay as close attention as I should. Question: I put back the. stock. Mesa EL34s in no real order and it occurred to me it may not be a matched quad, is there a way to tell if its a matched quad and if not what tube goes where.
 
There is a color code on the tube labels, “GRN”, “YEL”, etc.

I’m not sure if the Badlander has the tubes in inside & outside pairs or left and right pairs but as long as you keep the same color code in pairs you’re fine.

I would think they are in inside and outside pairs.

Dom
 

Latest posts

Back
Top